summaryrefslogtreecommitdiff
path: root/test/core/visual_identifier.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-08-08 02:54:55 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-08-08 03:03:03 +0300
commitc7e543ff2382036b7ddc97af700164aa401f069f (patch)
tree0802a9d9b8415a4bfa37129d4a9a73d4b4441a88 /test/core/visual_identifier.spec
parente35f7a0c488a128354caae176cc2fc8df1b129c7 (diff)
parent424d41761d819e127309af0c31837b91f2bb24a1 (diff)
Merge branch 'fix_colors' into prepare_066
Diffstat (limited to 'test/core/visual_identifier.spec')
-rwxr-xr-xtest/core/visual_identifier.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/core/visual_identifier.spec b/test/core/visual_identifier.spec
index c6b1125b..8c8e3177 100755
--- a/test/core/visual_identifier.spec
+++ b/test/core/visual_identifier.spec
@@ -18,7 +18,7 @@ function testOverwritingIconsWork() {
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
local POWERLEVEL9K_CUSTOM_WORLD1_ICON='icon-here'
- assertEquals "%K{white} %F{black%}icon-here %f%F{black}world1 %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000%}icon-here %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
}
function testVisualIdentifierAppearsBeforeSegmentContentOnLeftSegments() {
@@ -27,7 +27,7 @@ function testVisualIdentifierAppearsBeforeSegmentContentOnLeftSegments() {
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
local POWERLEVEL9K_CUSTOM_WORLD1_ICON='icon-here'
- assertEquals "%K{white} %F{black%}icon-here %f%F{black}world1 %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000%}icon-here %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
}
function testVisualIdentifierAppearsAfterSegmentContentOnRightSegments() {
@@ -36,7 +36,7 @@ function testVisualIdentifierAppearsAfterSegmentContentOnRightSegments() {
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
local POWERLEVEL9K_CUSTOM_WORLD1_ICON='icon-here'
- assertEquals "%F{white}%f%K{white}%F{black} world1%F{black%} icon-here%f%E" "$(build_right_prompt)"
+ assertEquals "%F{015}%f%K{015}%F{000} world1%F{000%} icon-here%f%E" "$(build_right_prompt)"
}
function testVisualIdentifierPrintsNothingIfNotAvailable() {
@@ -44,7 +44,7 @@ function testVisualIdentifierPrintsNothingIfNotAvailable() {
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world1)
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
- assertEquals "%K{white} %F{black}world1 %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
}
source shunit2/shunit2 \ No newline at end of file