aboutsummaryrefslogtreecommitdiff
path: root/test/core/visual_identifier.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-08-09 01:28:50 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-08-09 01:28:50 +0300
commite0630d75736aa274f09545f9849c035c0c6cab9b (patch)
tree764814982754ee87313998d5037db96f0a3bae4a /test/core/visual_identifier.spec
parentc7e543ff2382036b7ddc97af700164aa401f069f (diff)
parentef5f9bb1b494bcb1ceb81f7c833750d85701ca4a (diff)
Merge branch 'fix_colors' into prepare_066
Diffstat (limited to 'test/core/visual_identifier.spec')
-rwxr-xr-xtest/core/visual_identifier.spec16
1 files changed, 13 insertions, 3 deletions
diff --git a/test/core/visual_identifier.spec b/test/core/visual_identifier.spec
index 8c8e3177..c31f8dac 100755
--- a/test/core/visual_identifier.spec
+++ b/test/core/visual_identifier.spec
@@ -18,7 +18,7 @@ function testOverwritingIconsWork() {
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
local POWERLEVEL9K_CUSTOM_WORLD1_ICON='icon-here'
- assertEquals "%K{015} %F{000%}icon-here %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}icon-here %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
}
function testVisualIdentifierAppearsBeforeSegmentContentOnLeftSegments() {
@@ -27,7 +27,7 @@ function testVisualIdentifierAppearsBeforeSegmentContentOnLeftSegments() {
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
local POWERLEVEL9K_CUSTOM_WORLD1_ICON='icon-here'
- assertEquals "%K{015} %F{000%}icon-here %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}icon-here %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
}
function testVisualIdentifierAppearsAfterSegmentContentOnRightSegments() {
@@ -36,7 +36,7 @@ function testVisualIdentifierAppearsAfterSegmentContentOnRightSegments() {
local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
local POWERLEVEL9K_CUSTOM_WORLD1_ICON='icon-here'
- assertEquals "%F{015}%f%K{015}%F{000} world1%F{000%} icon-here%f%E" "$(build_right_prompt)"
+ assertEquals "%F{015}%f%K{015}%F{000} world1%F{000} icon-here%f%E" "$(build_right_prompt)"
}
function testVisualIdentifierPrintsNothingIfNotAvailable() {
@@ -47,4 +47,14 @@ function testVisualIdentifierPrintsNothingIfNotAvailable() {
assertEquals "%K{015} %F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
}
+function testVisualIdentifierIsPrintedInNumericalColorCode() {
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world1)
+ local POWERLEVEL9K_CUSTOM_WORLD1='echo world1'
+ local POWERLEVEL9K_CUSTOM_WORLD1_ICON="xxx"
+ local POWERLEVEL9K_CUSTOM_WORLD1_VISUAL_IDENTIFIER_COLOR="purple3"
+
+ assertEquals "%K{015} %F{056}xxx %f%F{000}world1 %k%F{015}%f " "$(build_left_prompt)"
+}
+
source shunit2/shunit2 \ No newline at end of file