aboutsummaryrefslogtreecommitdiff
path: root/test/functions/colors.spec
diff options
context:
space:
mode:
authorYang Tang <ytang@users.noreply.github.com>2018-10-12 18:29:50 +0300
committerGitHub <noreply@github.com>2018-10-12 18:29:50 +0300
commita98fa7ff54a0dc7b926deec99b69d5a0a0864a94 (patch)
treeb35d3df1b0ad12324f4094af98a576c6c933571e /test/functions/colors.spec
parent24bbbfc9bdbdc0666a53cd4a60a8b57551e9f0ca (diff)
parentb16c0d51d65249f0fdea86cd12cd64f6f0643b7e (diff)
Merge branch 'master' into fix-rprompt-icons-cut-off
Diffstat (limited to 'test/functions/colors.spec')
-rwxr-xr-xtest/functions/colors.spec31
1 files changed, 28 insertions, 3 deletions
diff --git a/test/functions/colors.spec b/test/functions/colors.spec
index 61a40087..4ee71205 100755
--- a/test/functions/colors.spec
+++ b/test/functions/colors.spec
@@ -22,6 +22,10 @@ function testGetColorCodeWithNumericalColor() {
assertEquals '002' "$(getColorCode '002')"
}
+function testGetColorCodeWithNoneColor() {
+ assertEquals 'none' "$(getColorCode 'NONE')"
+}
+
function testIsSameColorComparesAnsiForegroundAndNumericalColorCorrectly() {
assertTrue "isSameColor 'green' '002'"
}
@@ -30,13 +34,34 @@ function testIsSameColorComparesAnsiBackgroundAndNumericalColorCorrectly() {
assertTrue "isSameColor 'bg-green' '002'"
}
-function testIsSameColorComparesNumericalBackgroundAndNumericalColorCorrectly() {
- assertTrue "isSameColor '010' '2'"
+function testIsSameColorComparesShortCodesCorrectly() {
+ assertTrue "isSameColor '002' '2'"
}
function testIsSameColorDoesNotYieldNotEqualColorsTruthy() {
assertFalse "isSameColor 'green' '003'"
}
+function testIsSameColorHandlesNoneCorrectly() {
+ assertTrue "isSameColor 'none' 'NOnE'"
+}
+
+function testIsSameColorCompareTwoNoneColorsCorrectly() {
+ assertTrue "isSameColor 'none' 'none'"
+}
+
+function testIsSameColorComparesColorWithNoneCorrectly() {
+ assertFalse "isSameColor 'green' 'none'"
+}
+
+function testBrightColorsWork() {
+ # We had some code in the past that equalized bright colors
+ # with normal ones. This code is now gone, and this test should
+ # ensure that all input channels for bright colors are handled
+ # correctly.
+ assertTrue "isSameColor 'cyan' '006'"
+ assertEquals '006' "$(getColorCode 'cyan')"
+ assertEquals '006' "$(getColor 'cyan')"
+}
-source shunit2/source/2.1/src/shunit2
+source shunit2/shunit2