aboutsummaryrefslogtreecommitdiff
path: root/test/functions/colors.spec
diff options
context:
space:
mode:
authorromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
committerromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
commitceae2d7422545ae493c6dbf0217d234fb28e2ebc (patch)
tree24d273988a2e9a84d916b915ae094bf5d78255e9 /test/functions/colors.spec
parent71b763b69278e43736e5821c4c5d35f51c643ee2 (diff)
remove most things
Diffstat (limited to 'test/functions/colors.spec')
-rwxr-xr-xtest/functions/colors.spec67
1 files changed, 0 insertions, 67 deletions
diff --git a/test/functions/colors.spec b/test/functions/colors.spec
deleted file mode 100755
index 4ee71205..00000000
--- a/test/functions/colors.spec
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/usr/bin/env zsh
-#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
-
-# Required for shunit2 to run correctly
-setopt shwordsplit
-SHUNIT_PARENT=$0
-
-function setUp() {
- # Load Powerlevel9k
- source functions/colors.zsh
-}
-
-function testGetColorCodeWithAnsiForegroundColor() {
- assertEquals '002' "$(getColorCode 'green')"
-}
-
-function testGetColorCodeWithAnsiBackgroundColor() {
- assertEquals '002' "$(getColorCode 'bg-green')"
-}
-
-function testGetColorCodeWithNumericalColor() {
- assertEquals '002' "$(getColorCode '002')"
-}
-
-function testGetColorCodeWithNoneColor() {
- assertEquals 'none' "$(getColorCode 'NONE')"
-}
-
-function testIsSameColorComparesAnsiForegroundAndNumericalColorCorrectly() {
- assertTrue "isSameColor 'green' '002'"
-}
-
-function testIsSameColorComparesAnsiBackgroundAndNumericalColorCorrectly() {
- assertTrue "isSameColor 'bg-green' '002'"
-}
-
-function testIsSameColorComparesShortCodesCorrectly() {
- assertTrue "isSameColor '002' '2'"
-}
-
-function testIsSameColorDoesNotYieldNotEqualColorsTruthy() {
- assertFalse "isSameColor 'green' '003'"
-}
-
-function testIsSameColorHandlesNoneCorrectly() {
- assertTrue "isSameColor 'none' 'NOnE'"
-}
-
-function testIsSameColorCompareTwoNoneColorsCorrectly() {
- assertTrue "isSameColor 'none' 'none'"
-}
-
-function testIsSameColorComparesColorWithNoneCorrectly() {
- assertFalse "isSameColor 'green' 'none'"
-}
-
-function testBrightColorsWork() {
- # We had some code in the past that equalized bright colors
- # with normal ones. This code is now gone, and this test should
- # ensure that all input channels for bright colors are handled
- # correctly.
- assertTrue "isSameColor 'cyan' '006'"
- assertEquals '006' "$(getColorCode 'cyan')"
- assertEquals '006' "$(getColor 'cyan')"
-}
-
-source shunit2/shunit2