aboutsummaryrefslogtreecommitdiff
path: root/test/functions/colors.spec
diff options
context:
space:
mode:
authorBen Hilburn <bhilburn@gmail.com>2016-02-18 02:39:55 +0300
committerBen Hilburn <bhilburn@gmail.com>2016-02-18 02:39:55 +0300
commit64d81a2b36a705bbfe5be49e45695b059fa6a16a (patch)
tree589662162c57ef5bc14e709da8e62212168a3709 /test/functions/colors.spec
parent2d196fa12ffcd579ea310ad676aac9af51e360b2 (diff)
parent7efc6e41873e6c329f3b66e43ec853a85f0ad5e9 (diff)
Merge pull request #212 from dritter/unit_testing
Adding Unit Tests, supported by Travis-CI
Diffstat (limited to 'test/functions/colors.spec')
-rwxr-xr-xtest/functions/colors.spec42
1 files changed, 42 insertions, 0 deletions
diff --git a/test/functions/colors.spec b/test/functions/colors.spec
new file mode 100755
index 00000000..61a40087
--- /dev/null
+++ b/test/functions/colors.spec
@@ -0,0 +1,42 @@
+#!/usr/bin/env zsh
+#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
+
+# Required for shunit2 to run correctly
+setopt shwordsplit
+SHUNIT_PARENT=$0
+
+function setUp() {
+ # Load Powerlevel9k
+ source functions/colors.zsh
+}
+
+function testGetColorCodeWithAnsiForegroundColor() {
+ assertEquals '002' "$(getColorCode 'green')"
+}
+
+function testGetColorCodeWithAnsiBackgroundColor() {
+ assertEquals '002' "$(getColorCode 'bg-green')"
+}
+
+function testGetColorCodeWithNumericalColor() {
+ assertEquals '002' "$(getColorCode '002')"
+}
+
+function testIsSameColorComparesAnsiForegroundAndNumericalColorCorrectly() {
+ assertTrue "isSameColor 'green' '002'"
+}
+
+function testIsSameColorComparesAnsiBackgroundAndNumericalColorCorrectly() {
+ assertTrue "isSameColor 'bg-green' '002'"
+}
+
+function testIsSameColorComparesNumericalBackgroundAndNumericalColorCorrectly() {
+ assertTrue "isSameColor '010' '2'"
+}
+
+function testIsSameColorDoesNotYieldNotEqualColorsTruthy() {
+ assertFalse "isSameColor 'green' '003'"
+}
+
+
+source shunit2/source/2.1/src/shunit2