aboutsummaryrefslogtreecommitdiff
path: root/test/functions/colors.spec
diff options
context:
space:
mode:
authorBen Hilburn <bhilburn@gmail.com>2018-08-31 22:43:20 +0300
committerGitHub <noreply@github.com>2018-08-31 22:43:20 +0300
commite207dec8de036112fcac8b8face41e87e1d0b7ec (patch)
treecf455c0cb6d45464008d1b14877cef910a368ea6 /test/functions/colors.spec
parent571a859413866897cf962396f02f65a288f677ac (diff)
parent69c69b9cd91d77178324a86d8924efccadaa7247 (diff)
Merge pull request #944 from dritter/prepare_066
Preparing for v0.6.6 release!
Diffstat (limited to 'test/functions/colors.spec')
-rwxr-xr-xtest/functions/colors.spec31
1 files changed, 28 insertions, 3 deletions
diff --git a/test/functions/colors.spec b/test/functions/colors.spec
index 61a40087..ce777913 100755
--- a/test/functions/colors.spec
+++ b/test/functions/colors.spec
@@ -22,6 +22,10 @@ function testGetColorCodeWithNumericalColor() {
assertEquals '002' "$(getColorCode '002')"
}
+function testGetColorCodeWithNoneColor() {
+ assertEquals 'none' "$(getColorCode 'NONE')"
+}
+
function testIsSameColorComparesAnsiForegroundAndNumericalColorCorrectly() {
assertTrue "isSameColor 'green' '002'"
}
@@ -30,13 +34,34 @@ function testIsSameColorComparesAnsiBackgroundAndNumericalColorCorrectly() {
assertTrue "isSameColor 'bg-green' '002'"
}
-function testIsSameColorComparesNumericalBackgroundAndNumericalColorCorrectly() {
- assertTrue "isSameColor '010' '2'"
+function testIsSameColorComparesShortCodesCorrectly() {
+ assertTrue "isSameColor '002' '2'"
}
function testIsSameColorDoesNotYieldNotEqualColorsTruthy() {
assertFalse "isSameColor 'green' '003'"
}
+function testIsSameColorHandlesNoneCorrectly() {
+ assertTrue "isSameColor 'none' 'NOnE'"
+}
+
+function testIsSameColorCompareTwoNoneColorsCorrectly() {
+ assertTrue "isSameColor 'none' 'none'"
+}
+
+function testIsSameColorComparesColorWithNoneCorrectly() {
+ assertFalse "isSameColor 'green' 'none'"
+}
+
+function testBrightColorsWork() {
+ # We had some code in the past that equalized bright colors
+ # with normal ones. This code is now gone, and this test should
+ # ensure that all input channels for bright colors are handled
+ # correctly.
+ assertTrue "isSameColor 'cyan' '014'"
+ assertEquals '014' "$(getColorCode 'cyan')"
+ assertEquals '014' "$(getColor 'cyan')"
+}
-source shunit2/source/2.1/src/shunit2
+source shunit2/shunit2