summaryrefslogtreecommitdiff
path: root/test/powerlevel9k.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-06-07 02:36:56 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-06-07 02:51:16 +0300
commitd9d9fb9b6b9ede92fe76682c0fa4e03a29853695 (patch)
tree4fceb0d6b41f5b992cb92f14bcf209881010e10b /test/powerlevel9k.spec
parent5eedb2586be2c0107ebd159d50833664c612ce69 (diff)
parent9c4203bdf80440b43b5f559b5d8856f6b817ad9e (diff)
Merge remote-tracking branch 'ytang/fix-icons-cut-off' into staging_065
Conflicts were: - test/segments/command_execution_time.spec and test/segments/go_version.spec: All conflicts come from renaming color names on next (#703) and adding a whitespace to the Visual Identifier (#854) on master.
Diffstat (limited to 'test/powerlevel9k.spec')
-rwxr-xr-xtest/powerlevel9k.spec6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/powerlevel9k.spec b/test/powerlevel9k.spec
index 4178a4f6..16043d00 100755
--- a/test/powerlevel9k.spec
+++ b/test/powerlevel9k.spec
@@ -65,7 +65,7 @@ function testDynamicColoringOfVisualIdentifiersWork() {
cd /tmp
- assertEquals "%K{blue} %F{green%}icon-here%f %F{black}/tmp %k%F{blue}%f " "$(build_left_prompt)"
+ assertEquals "%K{blue} %F{green%}icon-here %f%F{black}/tmp %k%F{blue}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
unset POWERLEVEL9K_DIR_DEFAULT_VISUAL_IDENTIFIER_COLOR
@@ -86,7 +86,7 @@ function testColoringOfVisualIdentifiersDoesNotOverwriteColoringOfSegment() {
cd /tmp
- assertEquals "%K{yellow} %F{green%}icon-here%f %F{red}/tmp %k%F{yellow}%f " "$(build_left_prompt)"
+ assertEquals "%K{yellow} %F{green%}icon-here %f%F{red}/tmp %k%F{yellow}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
unset POWERLEVEL9K_DIR_DEFAULT_VISUAL_IDENTIFIER_COLOR
@@ -106,7 +106,7 @@ function testOverwritingIconsWork() {
#cd ~/$testFolder
cd /tmp
- assertEquals "%K{blue} %F{black%}icon-here%f %F{black}/tmp %k%F{blue}%f " "$(build_left_prompt)"
+ assertEquals "%K{blue} %F{black%}icon-here %f%F{black}/tmp %k%F{blue}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
unset POWERLEVEL9K_DIR_FOLDER_ICON