aboutsummaryrefslogtreecommitdiff
path: root/test/segments/anaconda.spec
diff options
context:
space:
mode:
authorBen Hilburn <bhilburn@gmail.com>2018-08-31 22:43:20 +0300
committerGitHub <noreply@github.com>2018-08-31 22:43:20 +0300
commite207dec8de036112fcac8b8face41e87e1d0b7ec (patch)
treecf455c0cb6d45464008d1b14877cef910a368ea6 /test/segments/anaconda.spec
parent571a859413866897cf962396f02f65a288f677ac (diff)
parent69c69b9cd91d77178324a86d8924efccadaa7247 (diff)
Merge pull request #944 from dritter/prepare_066
Preparing for v0.6.6 release!
Diffstat (limited to 'test/segments/anaconda.spec')
-rwxr-xr-xtest/segments/anaconda.spec69
1 files changed, 69 insertions, 0 deletions
diff --git a/test/segments/anaconda.spec b/test/segments/anaconda.spec
new file mode 100755
index 00000000..92e1ea64
--- /dev/null
+++ b/test/segments/anaconda.spec
@@ -0,0 +1,69 @@
+#!/usr/bin/env zsh
+#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
+
+# Required for shunit2 to run correctly
+setopt shwordsplit
+SHUNIT_PARENT=$0
+
+function setUp() {
+ export TERM="xterm-256color"
+}
+
+function testAnacondaSegmentPrintsNothingIfNoAnacondaPathIsSet() {
+ local POWERLEVEL9K_CUSTOM_WORLD='echo world'
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda custom_world)
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ # Unset anacona variables
+ unset CONDA_ENV_PATH
+ unset CONDA_PREFIX
+
+ assertEquals "%K{015} %F{000}world %k%F{015}%f " "$(build_left_prompt)"
+}
+
+function testAnacondaSegmentWorksIfOnlyAnacondaPathIsSet() {
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda)
+ local POWERLEVEL9K_PYTHON_ICON="icon-here"
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ CONDA_ENV_PATH=/tmp
+ unset CONDA_PREFIX
+
+ assertEquals "%K{012} %F{000}icon-here %f%F{000}(tmp) %k%F{012}%f " "$(build_left_prompt)"
+}
+
+function testAnacondaSegmentWorksIfOnlyAnacondaPrefixIsSet() {
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda)
+ local POWERLEVEL9K_PYTHON_ICON="icon-here"
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ unset CONDA_ENV_PATH
+ local CONDA_PREFIX="test"
+
+ assertEquals "%K{012} %F{000}icon-here %f%F{000}(test) %k%F{012}%f " "$(build_left_prompt)"
+}
+
+function testAnacondaSegmentWorks() {
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda)
+ local POWERLEVEL9K_PYTHON_ICON="icon-here"
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ local CONDA_ENV_PATH=/tmp
+ local CONDA_PREFIX="test"
+
+ assertEquals "%K{012} %F{000}icon-here %f%F{000}(tmptest) %k%F{012}%f " "$(build_left_prompt)"
+}
+
+source shunit2/shunit2 \ No newline at end of file