aboutsummaryrefslogtreecommitdiff
path: root/test/segments/aws_eb_env.spec
diff options
context:
space:
mode:
authorYang Tang <ytang@users.noreply.github.com>2018-10-12 18:29:50 +0300
committerGitHub <noreply@github.com>2018-10-12 18:29:50 +0300
commita98fa7ff54a0dc7b926deec99b69d5a0a0864a94 (patch)
treeb35d3df1b0ad12324f4094af98a576c6c933571e /test/segments/aws_eb_env.spec
parent24bbbfc9bdbdc0666a53cd4a60a8b57551e9f0ca (diff)
parentb16c0d51d65249f0fdea86cd12cd64f6f0643b7e (diff)
Merge branch 'master' into fix-rprompt-icons-cut-off
Diffstat (limited to 'test/segments/aws_eb_env.spec')
-rwxr-xr-xtest/segments/aws_eb_env.spec61
1 files changed, 61 insertions, 0 deletions
diff --git a/test/segments/aws_eb_env.spec b/test/segments/aws_eb_env.spec
new file mode 100755
index 00000000..99b418e0
--- /dev/null
+++ b/test/segments/aws_eb_env.spec
@@ -0,0 +1,61 @@
+#!/usr/bin/env zsh
+#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
+
+# Required for shunit2 to run correctly
+setopt shwordsplit
+SHUNIT_PARENT=$0
+
+function setUp() {
+ export TERM="xterm-256color"
+}
+
+function testAwsEbEnvSegmentPrintsNothingIfNoElasticBeanstalkEnvironmentIsSet() {
+ local POWERLEVEL9K_CUSTOM_WORLD='echo world'
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(aws_eb_env custom_world)
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ assertEquals "%K{007} %F{000}world %k%F{007}%f " "$(build_left_prompt)"
+}
+
+function testAwsEbEnvSegmentWorksIfElasticBeanstalkEnvironmentIsSet() {
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(aws_eb_env)
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ mkdir -p /tmp/powerlevel9k-test/.elasticbeanstalk
+ echo "test:\n environment: test" > /tmp/powerlevel9k-test/.elasticbeanstalk/config.yml
+ cd /tmp/powerlevel9k-test
+
+ assertEquals "%K{000} %F{002}🌱 %f%F{002}test %k%F{000}%f " "$(build_left_prompt)"
+
+ rm -fr /tmp/powerlevel9k-test
+ cd -
+}
+
+function testAwsEbEnvSegmentWorksIfElasticBeanstalkEnvironmentIsSetInParentDirectory() {
+ # Skip test, because currently we cannot detect
+ # if the configuration is in a parent directory
+ startSkipping # Skip test
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(aws_eb_env)
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ mkdir -p /tmp/powerlevel9k-test/.elasticbeanstalk
+ mkdir -p /tmp/powerlevel9k-test/1/12/123/1234/12345
+ echo "test:\n environment: test" > /tmp/powerlevel9k-test/.elasticbeanstalk/config.yml
+ cd /tmp/powerlevel9k-test/1/12/123/1234/12345
+
+ assertEquals "%K{000} %F{002}🌱 %f%F{002}test %k%F{000}%f " "$(build_left_prompt)"
+
+ rm -fr /tmp/powerlevel9k-test
+ cd -
+}
+
+source shunit2/shunit2 \ No newline at end of file