aboutsummaryrefslogtreecommitdiff
path: root/test/segments/battery.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-08-04 23:57:06 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-08-04 23:57:06 +0300
commite7cbcc5187c99e236192c1e3801bef54fd682c21 (patch)
tree96a49b19c9822e2746718f5864e489b25781d202 /test/segments/battery.spec
parent81fd69ae98337c20cb3e530d4efe13bec2fb3b20 (diff)
Fix tests
Diffstat (limited to 'test/segments/battery.spec')
-rwxr-xr-xtest/segments/battery.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/segments/battery.spec b/test/segments/battery.spec
index 4f81eaec..754de3cf 100755
--- a/test/segments/battery.spec
+++ b/test/segments/battery.spec
@@ -158,6 +158,10 @@ function testBatterySegmentIfBatteryIsNormalWithAcpiEnabledOnLinux() {
assertEquals "%K{black} %F{white%}🔋 %f%F{white}50%% (1:38) " "$(prompt_battery left 1 false ${FOLDER})"
unalias date &>/dev/null
+ # unaliasing date fails where it was never aliased (e.g. on Linux).
+ # This causes the whole test to fail, because the return code is
+ # non-zero.
+ return 0
}
function testBatterySegmentIfBatteryIsCalculatingWithAcpiEnabledOnLinux() {