aboutsummaryrefslogtreecommitdiff
path: root/test/segments/detect_virt.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-08-08 02:54:55 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-08-08 03:03:03 +0300
commitc7e543ff2382036b7ddc97af700164aa401f069f (patch)
tree0802a9d9b8415a4bfa37129d4a9a73d4b4441a88 /test/segments/detect_virt.spec
parente35f7a0c488a128354caae176cc2fc8df1b129c7 (diff)
parent424d41761d819e127309af0c31837b91f2bb24a1 (diff)
Merge branch 'fix_colors' into prepare_066
Diffstat (limited to 'test/segments/detect_virt.spec')
-rwxr-xr-xtest/segments/detect_virt.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/segments/detect_virt.spec b/test/segments/detect_virt.spec
index f5c54198..e0ca80e7 100755
--- a/test/segments/detect_virt.spec
+++ b/test/segments/detect_virt.spec
@@ -20,7 +20,7 @@ function testDetectVirtSegmentPrintsNothingIfSystemdIsNotAvailable() {
# Load Powerlevel9k
source powerlevel9k.zsh-theme
- assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}world %k%F{015}%f " "$(build_left_prompt)"
unalias systemd-detect-virt
}
@@ -33,7 +33,7 @@ function testDetectVirtSegmentIfSystemdReturnsPlainName() {
# Load Powerlevel9k
source powerlevel9k.zsh-theme
- assertEquals "%K{black} %F{yellow}xxx %k%F{black}%f " "$(build_left_prompt)"
+ assertEquals "%K{000} %F{011}xxx %k%F{000}%f " "$(build_left_prompt)"
unalias systemd-detect-virt
}
@@ -53,7 +53,7 @@ function testDetectVirtSegmentIfRootFsIsOnExpectedInode() {
# which translates to: Show the inode number of "/" and test if it is "2".
alias ls="echo '2'"
- assertEquals "%K{black} %F{yellow}none %k%F{black}%f " "$(build_left_prompt)"
+ assertEquals "%K{000} %F{011}none %k%F{000}%f " "$(build_left_prompt)"
unalias ls
unalias systemd-detect-virt
@@ -74,7 +74,7 @@ function testDetectVirtSegmentIfRootFsIsNotOnExpectedInode() {
# which translates to: Show the inode number of "/" and test if it is "2".
alias ls="echo '3'"
- assertEquals "%K{black} %F{yellow}chroot %k%F{black}%f " "$(build_left_prompt)"
+ assertEquals "%K{000} %F{011}chroot %k%F{000}%f " "$(build_left_prompt)"
unalias ls
unalias systemd-detect-virt