summaryrefslogtreecommitdiff
path: root/test/segments/detect_virt.spec
diff options
context:
space:
mode:
authorromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
committerromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
commitceae2d7422545ae493c6dbf0217d234fb28e2ebc (patch)
tree24d273988a2e9a84d916b915ae094bf5d78255e9 /test/segments/detect_virt.spec
parent71b763b69278e43736e5821c4c5d35f51c643ee2 (diff)
remove most things
Diffstat (limited to 'test/segments/detect_virt.spec')
-rwxr-xr-xtest/segments/detect_virt.spec83
1 files changed, 0 insertions, 83 deletions
diff --git a/test/segments/detect_virt.spec b/test/segments/detect_virt.spec
deleted file mode 100755
index 910f52eb..00000000
--- a/test/segments/detect_virt.spec
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/usr/bin/env zsh
-#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
-
-# Required for shunit2 to run correctly
-setopt shwordsplit
-SHUNIT_PARENT=$0
-
-function setUp() {
- export TERM="xterm-256color"
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-}
-
-function testDetectVirtSegmentPrintsNothingIfSystemdIsNotAvailable() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(detect_virt custom_world)
- local POWERLEVEL9K_CUSTOM_WORLD='echo world'
- alias systemd-detect-virt="novirt"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- assertEquals "%K{007} %F{000}world %k%F{007}%f " "$(build_left_prompt)"
-
- unalias systemd-detect-virt
-}
-
-function testDetectVirtSegmentIfSystemdReturnsPlainName() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(detect_virt)
- alias systemd-detect-virt="echo 'xxx'"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- assertEquals "%K{000} %F{003}xxx %k%F{000}%f " "$(build_left_prompt)"
-
- unalias systemd-detect-virt
-}
-
-function testDetectVirtSegmentIfRootFsIsOnExpectedInode() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(detect_virt)
- # Well. This is a weak test, as it fixates the implementation,
- # but it is necessary, as the implementation relys on the root
- # directory having the inode number "2"..
- alias systemd-detect-virt="echo 'none'"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- # The original command in the implementation is "ls -di / | grep -o 2",
- # which translates to: Show the inode number of "/" and test if it is "2".
- alias ls="echo '2'"
-
- assertEquals "%K{000} %F{003}none %k%F{000}%f " "$(build_left_prompt)"
-
- unalias ls
- unalias systemd-detect-virt
-}
-
-function testDetectVirtSegmentIfRootFsIsNotOnExpectedInode() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(detect_virt)
- # Well. This is a weak test, as it fixates the implementation,
- # but it is necessary, as the implementation relys on the root
- # directory having the inode number "2"..
- alias systemd-detect-virt="echo 'none'"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- # The original command in the implementation is "ls -di / | grep -o 2",
- # which translates to: Show the inode number of "/" and test if it is "2".
- alias ls="echo '3'"
-
- assertEquals "%K{000} %F{003}chroot %k%F{000}%f " "$(build_left_prompt)"
-
- unalias ls
- unalias systemd-detect-virt
-}
-
-source shunit2/shunit2 \ No newline at end of file