summaryrefslogtreecommitdiff
path: root/test/segments/dir.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2017-07-12 04:29:31 +0300
committerDominik Ritter <dritter03@googlemail.com>2017-07-12 04:29:31 +0300
commita234636982349a82ab6c7f0674f3ff884acddc94 (patch)
tree044a37eb1716bd516884556045ddd9fbde28abba /test/segments/dir.spec
parent6735c24e621e435827f414103e8ab312c7eb8845 (diff)
Fix empty delimiter
Even if the delimiter is empty, the min length should be 1. This fixes #558
Diffstat (limited to 'test/segments/dir.spec')
-rwxr-xr-xtest/segments/dir.spec20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/segments/dir.spec b/test/segments/dir.spec
index b2991175..3a6af649 100755
--- a/test/segments/dir.spec
+++ b/test/segments/dir.spec
@@ -72,6 +72,26 @@ function testTruncationFromRightWorks() {
unset POWERLEVEL9K_SHORTEN_STRATEGY
}
+function testTruncationFromRightWithEmptyDelimiter() {
+ POWERLEVEL9K_SHORTEN_DIR_LENGTH=2
+ POWERLEVEL9K_SHORTEN_DELIMITER=""
+ POWERLEVEL9K_SHORTEN_STRATEGY='truncate_from_right'
+
+ FOLDER=/tmp/powerlevel9k-test/1/12/123/1234/12345/123456/1234567/12345678/123456789
+ mkdir -p $FOLDER
+ cd $FOLDER
+
+ assertEquals "%K{blue} %F{black}/tmp/po/1/12/123/12/12/12/12/12/123456789 %k%F{blue}%f " "$(build_left_prompt)"
+
+ cd -
+ rm -fr /tmp/powerlevel9k-test
+
+ unset FOLDER
+ unset POWERLEVEL9K_SHORTEN_DIR_LENGTH
+ unset POWERLEVEL9K_SHORTEN_DELIMITER
+ unset POWERLEVEL9K_SHORTEN_STRATEGY
+}
+
function testTruncateWithFolderMarkerWorks() {
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(dir)
POWERLEVEL9K_SHORTEN_STRATEGY="truncate_with_folder_marker"