summaryrefslogtreecommitdiff
path: root/test/segments/dir.spec
diff options
context:
space:
mode:
authorChristo Kotze <onaforeignshore@hotmail.co.uk>2018-02-23 09:08:43 +0300
committerChristo Kotze <onaforeignshore@hotmail.co.uk>2018-02-23 09:08:43 +0300
commitddcdad77a73d971a77283d90fd3ba78e0f61dc66 (patch)
tree4d4501c3fdb30d9d466c62db36f8de6eefcb2cca /test/segments/dir.spec
parentb723800b801f8bfc1aa997eea1f03d4279f96f3e (diff)
Added new variable POWERLEVEL9K_DIR_PATH_ABSOLUTE
If user sets POWERLEVEL9K_DIR_PATH_ABSOLUTE to true, uses absolute paths instead of home folder abbreviation, e.g. /Users/chris/... instead of ~/...
Diffstat (limited to 'test/segments/dir.spec')
-rwxr-xr-xtest/segments/dir.spec10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/segments/dir.spec b/test/segments/dir.spec
index 12242961..efe99672 100755
--- a/test/segments/dir.spec
+++ b/test/segments/dir.spec
@@ -18,6 +18,16 @@ function tearDown() {
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
}
+function testAbsolutePathWorks() {
+ POWERLEVEL9K_DIR_PATH_ABSOLUTE=true
+
+ cd ~
+ assertEquals "%K{blue} %F{black}…/12345678/123456789 %k%F{blue}%f " "$(build_left_prompt)"
+
+ cd -
+ unset POWERLEVEL9K_DIR_PATH_ABSOLUTE
+}
+
function testTruncateFoldersWorks() {
POWERLEVEL9K_SHORTEN_DIR_LENGTH=2
POWERLEVEL9K_SHORTEN_STRATEGY='truncate_folders'