summaryrefslogtreecommitdiff
path: root/test/segments/dir.spec
diff options
context:
space:
mode:
authorChristo Kotze <onaforeignshore@hotmail.co.uk>2018-02-14 12:30:21 +0300
committerChristo Kotze <onaforeignshore@hotmail.co.uk>2018-02-14 12:30:21 +0300
commit1e54872873270b89700c3f88783bdc301ba40e50 (patch)
tree21fd64b36b9263b49c0f276e4549612553bf0e8a /test/segments/dir.spec
parentb6f20d1032496d296a5aed4e059f7001195fb3d5 (diff)
Added test for Home folder highlighting
Diffstat (limited to 'test/segments/dir.spec')
-rwxr-xr-xtest/segments/dir.spec12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/segments/dir.spec b/test/segments/dir.spec
index d1a496e7..41f82eca 100755
--- a/test/segments/dir.spec
+++ b/test/segments/dir.spec
@@ -429,9 +429,11 @@ function testTruncateToUniqueWorks() {
function testBoldHomeDirectoryWorks() {
POWERLEVEL9K_DIR_PATH_HIGHLIGHT_BOLD=true
+ cd ~
assertEquals "%K{blue} %F{black}%B~%b %k%F{blue}%f " "$(build_left_prompt)"
+ cd -
unset POWERLEVEL9K_DIR_PATH_HIGHLIGHT_BOLD
}
@@ -445,4 +447,14 @@ function testBoldOtherDirectoryWorks() {
unset POWERLEVEL9K_DIR_PATH_HIGHLIGHT_BOLD
}
+function testDirHighlightHomeWorks() {
+ POWERLEVEL9K_DIR_PATH_HIGHLIGHT_FOREGROUND='red'
+ cd ~
+
+ assertEquals "%K{blue} %F{black}%F{red}~%b %k%F{blue}%f " "$(build_left_prompt)"
+
+ cd -
+ unset POWERLEVEL9K_DIR_PATH_HIGHLIGHT_FOREGROUND
+}
+
source shunit2/source/2.1/src/shunit2