aboutsummaryrefslogtreecommitdiff
path: root/test/segments/go_version.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-08-08 01:42:42 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-08-08 01:42:42 +0300
commite970a021c867976c52365c7d6b731b561539966e (patch)
tree44e16ca5bbdb969058a3b35ad338d4496835cc5a /test/segments/go_version.spec
parent19235b2359ce9307a1672cc79cdcfe4a207658e5 (diff)
Fix tests
Diffstat (limited to 'test/segments/go_version.spec')
-rwxr-xr-xtest/segments/go_version.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/segments/go_version.spec b/test/segments/go_version.spec
index 9104ac8b..30b157a5 100755
--- a/test/segments/go_version.spec
+++ b/test/segments/go_version.spec
@@ -40,7 +40,7 @@ function testGo() {
PWD="$HOME/go/src/github.com/bhilburn/powerlevel9k"
- assertEquals "%K{green} %F{grey93%} %f%F{grey93}go1.5.3 %k%F{green}%f " "$(build_left_prompt)"
+ assertEquals "%K{002} %F{255%} %f%F{255}go1.5.3 %k%F{002}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_GO_ICON
unset PWD
@@ -53,7 +53,7 @@ function testGoSegmentPrintsNothingIfEmptyGopath() {
POWERLEVEL9K_CUSTOM_WORLD='echo world'
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world go_version)
- assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}world %k%F{015}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
unset POWERLEVEL9K_CUSTOM_WORLD
@@ -65,7 +65,7 @@ function testGoSegmentPrintsNothingIfNotInGopath() {
POWERLEVEL9K_CUSTOM_WORLD='echo world'
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world go_version)
- assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}world %k%F{015}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
unset POWERLEVEL9K_CUSTOM_WORLD
@@ -76,7 +76,7 @@ function testGoSegmentPrintsNothingIfGoIsNotAvailable() {
POWERLEVEL9K_CUSTOM_WORLD='echo world'
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world go_version)
- assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
+ assertEquals "%K{015} %F{000}world %k%F{015}%f " "$(build_left_prompt)"
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
unset POWERLEVEL9K_CUSTOM_WORLD