aboutsummaryrefslogtreecommitdiff
path: root/test/segments/ram.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-07-19 23:39:19 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-07-19 23:39:19 +0300
commit16e5e14af747bb310dabd367648b5566cd2edc6b (patch)
tree9593ab0319da9f99bbc5dd29d437b092a806bfb7 /test/segments/ram.spec
parent4b32b2c0b246e65529e8e055c63be8d58be15f95 (diff)
Fix tests on older ZSH versions
Diffstat (limited to 'test/segments/ram.spec')
-rwxr-xr-xtest/segments/ram.spec3
1 files changed, 0 insertions, 3 deletions
diff --git a/test/segments/ram.spec b/test/segments/ram.spec
index 104b8c82..0deaacf9 100755
--- a/test/segments/ram.spec
+++ b/test/segments/ram.spec
@@ -28,7 +28,6 @@ function tearDown() {
}
function testRamSegmentWorksOnOsx() {
- local POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(ram)
local OS="OSX" # Fake OSX
alias vm_stat="echo 'Mach Virtual Memory Statistics: (page size of 4096 bytes)
Pages free: 299687.
@@ -42,7 +41,6 @@ Pages inactive: 1313411.
}
function testRamSegmentWorksOnBsd() {
- local POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(ram)
local OS="BSD" # Fake BSD
mkdir -p var/run
echo "avail memory 5678B 299687 4444G 299" > var/run/dmesg.boot
@@ -51,7 +49,6 @@ function testRamSegmentWorksOnBsd() {
}
function testRamSegmentWorksOnLinux() {
- local POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(ram)
local OS="Linux" # Fake Linux
mkdir proc
echo "MemAvailable: 299687" > proc/meminfo