aboutsummaryrefslogtreecommitdiff
path: root/test/segments/vi_mode.spec
diff options
context:
space:
mode:
authorDominik Ritter <dritter03@googlemail.com>2018-07-19 08:42:47 +0300
committerDominik Ritter <dritter03@googlemail.com>2018-07-19 08:42:47 +0300
commita5d9227fcb9110bc50d28f6e70bc67c918991f0d (patch)
tree36a24bcb6531dfb09a41938950f4fb9db075afd7 /test/segments/vi_mode.spec
parent671f826a4087ee35a399475712fe9cea4d4fc337 (diff)
Add tests for vi_mode segment
Diffstat (limited to 'test/segments/vi_mode.spec')
-rwxr-xr-xtest/segments/vi_mode.spec38
1 files changed, 38 insertions, 0 deletions
diff --git a/test/segments/vi_mode.spec b/test/segments/vi_mode.spec
new file mode 100755
index 00000000..205c38b7
--- /dev/null
+++ b/test/segments/vi_mode.spec
@@ -0,0 +1,38 @@
+#!/usr/bin/env zsh
+#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
+
+# Required for shunit2 to run correctly
+setopt shwordsplit
+SHUNIT_PARENT=$0
+
+function setUp() {
+ export TERM="xterm-256color"
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+}
+
+function testViInsertModeWorks() {
+ local KEYMAP='viins'
+
+ assertEquals "%K{black} %F{blue}INSERT " "$(prompt_vi_mode left 1 false)"
+}
+
+function testViInsertModeWorksWhenLabeledAsMain() {
+ local KEYMAP='main'
+
+ assertEquals "%K{black} %F{blue}INSERT " "$(prompt_vi_mode left 1 false)"
+}
+
+function testViCommandModeWorks() {
+ local KEYMAP='vicmd'
+
+ assertEquals "%K{black} %F{white}NORMAL " "$(prompt_vi_mode left 1 false)"
+}
+
+function testViInsertModeStringIsCustomizable() {
+ local KEYMAP='viins'
+
+ assertEquals "%K{black} %F{blue}INSERT " "$(prompt_vi_mode left 1 false)"
+}
+
+source shunit2/source/2.1/src/shunit2 \ No newline at end of file