summaryrefslogtreecommitdiff
path: root/test/segments/vi_mode.spec
diff options
context:
space:
mode:
authorBen Hilburn <bhilburn@gmail.com>2018-08-31 22:43:20 +0300
committerGitHub <noreply@github.com>2018-08-31 22:43:20 +0300
commite207dec8de036112fcac8b8face41e87e1d0b7ec (patch)
treecf455c0cb6d45464008d1b14877cef910a368ea6 /test/segments/vi_mode.spec
parent571a859413866897cf962396f02f65a288f677ac (diff)
parent69c69b9cd91d77178324a86d8924efccadaa7247 (diff)
Merge pull request #944 from dritter/prepare_066
Preparing for v0.6.6 release!
Diffstat (limited to 'test/segments/vi_mode.spec')
-rwxr-xr-xtest/segments/vi_mode.spec48
1 files changed, 48 insertions, 0 deletions
diff --git a/test/segments/vi_mode.spec b/test/segments/vi_mode.spec
new file mode 100755
index 00000000..8535cc4e
--- /dev/null
+++ b/test/segments/vi_mode.spec
@@ -0,0 +1,48 @@
+#!/usr/bin/env zsh
+#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
+
+# Required for shunit2 to run correctly
+setopt shwordsplit
+SHUNIT_PARENT=$0
+
+function setUp() {
+ export TERM="xterm-256color"
+}
+
+function testViInsertModeWorks() {
+ local KEYMAP='viins'
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ assertEquals "%K{000} %F{012}INSERT " "$(prompt_vi_mode left 1 false)"
+}
+
+function testViInsertModeWorksWhenLabeledAsMain() {
+ local KEYMAP='main'
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ assertEquals "%K{000} %F{012}INSERT " "$(prompt_vi_mode left 1 false)"
+}
+
+function testViCommandModeWorks() {
+ local KEYMAP='vicmd'
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ assertEquals "%K{000} %F{015}NORMAL " "$(prompt_vi_mode left 1 false)"
+}
+
+function testViInsertModeStringIsCustomizable() {
+ local KEYMAP='viins'
+
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
+ assertEquals "%K{000} %F{012}INSERT " "$(prompt_vi_mode left 1 false)"
+}
+
+source shunit2/shunit2 \ No newline at end of file