aboutsummaryrefslogtreecommitdiff
path: root/test/functions/colors.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/functions/colors.spec')
-rwxr-xr-xtest/functions/colors.spec42
1 files changed, 42 insertions, 0 deletions
diff --git a/test/functions/colors.spec b/test/functions/colors.spec
new file mode 100755
index 00000000..61a40087
--- /dev/null
+++ b/test/functions/colors.spec
@@ -0,0 +1,42 @@
+#!/usr/bin/env zsh
+#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
+
+# Required for shunit2 to run correctly
+setopt shwordsplit
+SHUNIT_PARENT=$0
+
+function setUp() {
+ # Load Powerlevel9k
+ source functions/colors.zsh
+}
+
+function testGetColorCodeWithAnsiForegroundColor() {
+ assertEquals '002' "$(getColorCode 'green')"
+}
+
+function testGetColorCodeWithAnsiBackgroundColor() {
+ assertEquals '002' "$(getColorCode 'bg-green')"
+}
+
+function testGetColorCodeWithNumericalColor() {
+ assertEquals '002' "$(getColorCode '002')"
+}
+
+function testIsSameColorComparesAnsiForegroundAndNumericalColorCorrectly() {
+ assertTrue "isSameColor 'green' '002'"
+}
+
+function testIsSameColorComparesAnsiBackgroundAndNumericalColorCorrectly() {
+ assertTrue "isSameColor 'bg-green' '002'"
+}
+
+function testIsSameColorComparesNumericalBackgroundAndNumericalColorCorrectly() {
+ assertTrue "isSameColor '010' '2'"
+}
+
+function testIsSameColorDoesNotYieldNotEqualColorsTruthy() {
+ assertFalse "isSameColor 'green' '003'"
+}
+
+
+source shunit2/source/2.1/src/shunit2