aboutsummaryrefslogtreecommitdiff
path: root/test/segments/battery.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/segments/battery.spec')
-rwxr-xr-xtest/segments/battery.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/segments/battery.spec b/test/segments/battery.spec
index 4f81eaec..754de3cf 100755
--- a/test/segments/battery.spec
+++ b/test/segments/battery.spec
@@ -158,6 +158,10 @@ function testBatterySegmentIfBatteryIsNormalWithAcpiEnabledOnLinux() {
assertEquals "%K{black} %F{white%}🔋 %f%F{white}50%% (1:38) " "$(prompt_battery left 1 false ${FOLDER})"
unalias date &>/dev/null
+ # unaliasing date fails where it was never aliased (e.g. on Linux).
+ # This causes the whole test to fail, because the return code is
+ # non-zero.
+ return 0
}
function testBatterySegmentIfBatteryIsCalculatingWithAcpiEnabledOnLinux() {