aboutsummaryrefslogtreecommitdiff
path: root/test/segments/dir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/segments/dir.spec')
-rwxr-xr-xtest/segments/dir.spec10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/segments/dir.spec b/test/segments/dir.spec
index 12242961..efe99672 100755
--- a/test/segments/dir.spec
+++ b/test/segments/dir.spec
@@ -18,6 +18,16 @@ function tearDown() {
unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
}
+function testAbsolutePathWorks() {
+ POWERLEVEL9K_DIR_PATH_ABSOLUTE=true
+
+ cd ~
+ assertEquals "%K{blue} %F{black}…/12345678/123456789 %k%F{blue}%f " "$(build_left_prompt)"
+
+ cd -
+ unset POWERLEVEL9K_DIR_PATH_ABSOLUTE
+}
+
function testTruncateFoldersWorks() {
POWERLEVEL9K_SHORTEN_DIR_LENGTH=2
POWERLEVEL9K_SHORTEN_STRATEGY='truncate_folders'