aboutsummaryrefslogtreecommitdiff
path: root/test/segments/rust_version.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/segments/rust_version.spec')
-rwxr-xr-xtest/segments/rust_version.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/segments/rust_version.spec b/test/segments/rust_version.spec
index 3d627498..583807a6 100755
--- a/test/segments/rust_version.spec
+++ b/test/segments/rust_version.spec
@@ -14,8 +14,6 @@ function setUp() {
PATH="${RUST_TEST_FOLDER}:${PATH}"
export TERM="xterm-256color"
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
}
function tearDown() {
@@ -33,6 +31,9 @@ function testRust() {
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(rust_version)
mockRust
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
assertEquals "%K{208} %F{black%}Rust %f%F{black}0.4.1a-alpha %k%F{darkorange}%f " "$(build_left_prompt)"
}
@@ -41,6 +42,9 @@ function testRustPrintsNothingIfRustIsNotAvailable() {
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world rust_version)
local POWERLEVEL9K_CUSTOM_WORLD='echo world'
+ # Load Powerlevel9k
+ source powerlevel9k.zsh-theme
+
assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
}