aboutsummaryrefslogtreecommitdiff
path: root/test/segments/todo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/segments/todo.spec')
-rwxr-xr-xtest/segments/todo.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/segments/todo.spec b/test/segments/todo.spec
index 1dae9a68..7f1d7fba 100755
--- a/test/segments/todo.spec
+++ b/test/segments/todo.spec
@@ -7,8 +7,6 @@ SHUNIT_PARENT=$0
function setUp() {
export TERM="xterm-256color"
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
P9K_HOME=$(pwd)
### Test specific
@@ -37,6 +35,9 @@ function testTodoSegmentPrintsNothingIfTodoShIsNotInstalled() {
POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(todo custom_world)
local POWERLEVEL9K_CUSTOM_WORLD='echo world'
+ # Load Powerlevel9k
+ source ${P9K_HOME}/powerlevel9k.zsh-theme
+
assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
}
@@ -48,6 +49,9 @@ function testTodoSegmentWorksAsExpected() {
echo 'echo "TODO: 34 of 100 tasks shown";' >> ${FOLDER}/bin/todo.sh
chmod +x ${FOLDER}/bin/todo.sh
+ # Load Powerlevel9k
+ source ${P9K_HOME}/powerlevel9k.zsh-theme
+
assertEquals "%K{244} %F{black%}☑ %f%F{black}100 %k%F{grey50}%f " "$(build_left_prompt)"
}