aboutsummaryrefslogtreecommitdiff
path: root/test/segments/vcs-git.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/segments/vcs-git.spec')
-rwxr-xr-xtest/segments/vcs-git.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/segments/vcs-git.spec b/test/segments/vcs-git.spec
index bb51766c..bb2aef5b 100755
--- a/test/segments/vcs-git.spec
+++ b/test/segments/vcs-git.spec
@@ -491,6 +491,8 @@ function testDetectingUntrackedFilesInCleanSubdirectoryWorks() {
}
function testBranchNameScriptingVulnerability() {
+ local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(vcs)
echo "#!/bin/sh\n\necho 'hacked'\n" > evil_script.sh
chmod +x evil_script.sh
@@ -498,7 +500,7 @@ function testBranchNameScriptingVulnerability() {
git add . 2>/dev/null
git commit -m "Initial commit" >/dev/null
- assertEquals "%K{002} %F{000} %f%F{000} \$(./evil_script.sh) %k%F{002}%f " "$(__p9k_build_left_prompt)"
+ assertEquals "%K{002} %F{000} %f%F{000} \$(./evil_script.sh) %k%F{002}%f " "$(build_left_prompt)"
}
source shunit2/shunit2