aboutsummaryrefslogtreecommitdiff
path: root/test/segments/anaconda.spec
diff options
context:
space:
mode:
authorromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
committerromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
commitceae2d7422545ae493c6dbf0217d234fb28e2ebc (patch)
tree24d273988a2e9a84d916b915ae094bf5d78255e9 /test/segments/anaconda.spec
parent71b763b69278e43736e5821c4c5d35f51c643ee2 (diff)
remove most things
Diffstat (limited to 'test/segments/anaconda.spec')
-rwxr-xr-xtest/segments/anaconda.spec69
1 files changed, 0 insertions, 69 deletions
diff --git a/test/segments/anaconda.spec b/test/segments/anaconda.spec
deleted file mode 100755
index a25aed9b..00000000
--- a/test/segments/anaconda.spec
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/usr/bin/env zsh
-#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
-
-# Required for shunit2 to run correctly
-setopt shwordsplit
-SHUNIT_PARENT=$0
-
-function setUp() {
- export TERM="xterm-256color"
-}
-
-function testAnacondaSegmentPrintsNothingIfNoAnacondaPathIsSet() {
- local POWERLEVEL9K_CUSTOM_WORLD='echo world'
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda custom_world)
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- # Unset anacona variables
- unset CONDA_ENV_PATH
- unset CONDA_PREFIX
-
- assertEquals "%K{007} %F{000}world %k%F{007}%f " "$(build_left_prompt)"
-}
-
-function testAnacondaSegmentWorksIfOnlyAnacondaPathIsSet() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda)
- local POWERLEVEL9K_PYTHON_ICON="icon-here"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- CONDA_ENV_PATH=/tmp
- unset CONDA_PREFIX
-
- assertEquals "%K{004} %F{000}icon-here %F{000}(tmp) %k%F{004}%f " "$(build_left_prompt)"
-}
-
-function testAnacondaSegmentWorksIfOnlyAnacondaPrefixIsSet() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda)
- local POWERLEVEL9K_PYTHON_ICON="icon-here"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- unset CONDA_ENV_PATH
- local CONDA_PREFIX="test"
-
- assertEquals "%K{004} %F{000}icon-here %F{000}(test) %k%F{004}%f " "$(build_left_prompt)"
-}
-
-function testAnacondaSegmentWorks() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(anaconda)
- local POWERLEVEL9K_PYTHON_ICON="icon-here"
-
- # Load Powerlevel9k
- source powerlevel9k.zsh-theme
-
- local CONDA_ENV_PATH=/tmp
- local CONDA_PREFIX="test"
-
- assertEquals "%K{004} %F{000}icon-here %F{000}(tmptest) %k%F{004}%f " "$(build_left_prompt)"
-}
-
-source shunit2/shunit2 \ No newline at end of file