aboutsummaryrefslogtreecommitdiff
path: root/test/segments/newline.spec
diff options
context:
space:
mode:
authorromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
committerromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
commitceae2d7422545ae493c6dbf0217d234fb28e2ebc (patch)
tree24d273988a2e9a84d916b915ae094bf5d78255e9 /test/segments/newline.spec
parent71b763b69278e43736e5821c4c5d35f51c643ee2 (diff)
remove most things
Diffstat (limited to 'test/segments/newline.spec')
-rwxr-xr-xtest/segments/newline.spec42
1 files changed, 0 insertions, 42 deletions
diff --git a/test/segments/newline.spec b/test/segments/newline.spec
deleted file mode 100755
index 7cd00a89..00000000
--- a/test/segments/newline.spec
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/usr/bin/env zsh
-#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
-
-# Required for shunit2 to run correctly
-setopt shwordsplit
-SHUNIT_PARENT=$0
-
-function setUp() {
- export TERM="xterm-256color"
-
- P9K_HOME=$(pwd)
- ### Test specific
-}
-
-function testNewlineDoesNotCreateExtraSegmentSeparator() {
- local POWERLEVEL9K_CUSTOM_WORLD1="echo world1"
- local POWERLEVEL9K_CUSTOM_WORLD2="echo world2"
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world1 newline newline newline custom_world2)
-
- # Load Powerlevel9k
- source ${P9K_HOME}/powerlevel9k.zsh-theme
- local OS="OSX" # Fake OSX
-
- local newline=$'\n'
-
- assertEquals "%K{007} %F{000}world1 %k%F{007}%f${newline}%k%f${newline}%k%f${newline}%K{007} %F{000}world2 %k%F{007}%f " "$(build_left_prompt)"
-}
-
-function testNewlineMakesPreviousSegmentEndWell() {
- local POWERLEVEL9K_CUSTOM_WORLD1="echo world1"
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world1 newline)
-
- # Load Powerlevel9k
- source ${P9K_HOME}/powerlevel9k.zsh-theme
- local OS="OSX" # Fake OSX
-
- local newline=$'\n'
-
- assertEquals "%K{007} %F{000}world1 %k%F{007}%f${newline}%k%F{none}%f " "$(build_left_prompt)"
-}
-
-source shunit2/shunit2 \ No newline at end of file