aboutsummaryrefslogtreecommitdiff
path: root/test/segments/swap.spec
diff options
context:
space:
mode:
authorromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
committerromkatv <roman.perepelitsa@gmail.com>2019-03-01 23:45:36 +0300
commitceae2d7422545ae493c6dbf0217d234fb28e2ebc (patch)
tree24d273988a2e9a84d916b915ae094bf5d78255e9 /test/segments/swap.spec
parent71b763b69278e43736e5821c4c5d35f51c643ee2 (diff)
remove most things
Diffstat (limited to 'test/segments/swap.spec')
-rwxr-xr-xtest/segments/swap.spec58
1 files changed, 0 insertions, 58 deletions
diff --git a/test/segments/swap.spec b/test/segments/swap.spec
deleted file mode 100755
index 07b254be..00000000
--- a/test/segments/swap.spec
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/usr/bin/env zsh
-#vim:ft=zsh ts=2 sw=2 sts=2 et fenc=utf-8
-
-# Required for shunit2 to run correctly
-setopt shwordsplit
-SHUNIT_PARENT=$0
-
-function setUp() {
- export TERM="xterm-256color"
-
- P9K_HOME=$(pwd)
- ### Test specific
- # Create default folder and git init it.
- FOLDER=/tmp/powerlevel9k-test/swap-test
- mkdir -p "${FOLDER}"
- cd $FOLDER
-}
-
-function tearDown() {
- # Go back to powerlevel9k folder
- cd "${P9K_HOME}"
- # Remove eventually created test-specific folder
- rm -fr "${FOLDER}"
- # At least remove test folder completely
- rm -fr /tmp/powerlevel9k-test
-}
-
-function testSwapSegmentWorksOnOsx() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(swap)
- sysctl() {
- echo "vm.swapusage: total = 3072,00M used = 1620,50M free = 1451,50M (encrypted)"
- }
-
- # Load Powerlevel9k
- source ${P9K_HOME}/powerlevel9k.zsh-theme
- local OS="OSX" # Fake OSX
-
- assertEquals "%K{003} %F{000}SWP %F{000}1.58G " "$(prompt_swap left 1 false ${FOLDER})"
-
- unfunction sysctl
-}
-
-function testSwapSegmentWorksOnLinux() {
- local -a POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
- POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(swap)
- mkdir proc
- echo "SwapTotal: 1000000" > proc/meminfo
- echo "SwapFree: 1000" >> proc/meminfo
-
- # Load Powerlevel9k
- source ${P9K_HOME}/powerlevel9k.zsh-theme
- local OS="Linux" # Fake Linux
-
- assertEquals "%K{003} %F{000}SWP %F{000}0.95G " "$(prompt_swap left 1 false ${FOLDER})"
-}
-
-source shunit2/shunit2 \ No newline at end of file