aboutsummaryrefslogtreecommitdiff
path: root/test/segments/go_version.spec
diff options
context:
space:
mode:
Diffstat (limited to 'test/segments/go_version.spec')
-rwxr-xr-xtest/segments/go_version.spec11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/segments/go_version.spec b/test/segments/go_version.spec
index a085f3b3..3bbad1be 100755
--- a/test/segments/go_version.spec
+++ b/test/segments/go_version.spec
@@ -35,6 +35,17 @@ function testGo() {
unalias go
}
+function testGoSegmentPrintsNothingIfNotInGopath() {
+ alias go=mockGo
+ POWERLEVEL9K_CUSTOM_WORLD='echo world'
+ POWERLEVEL9K_LEFT_PROMPT_ELEMENTS=(custom_world go_version)
+
+ assertEquals "%K{white} %F{black}world %k%F{white}%f " "$(build_left_prompt)"
+
+ unset POWERLEVEL9K_LEFT_PROMPT_ELEMENTS
+ unset POWERLEVEL9K_CUSTOM_WORLD
+}
+
function testGoSegmentPrintsNothingIfGoIsNotAvailable() {
alias go=noGo
POWERLEVEL9K_CUSTOM_WORLD='echo world'